Archive

Archive for the ‘Troubleshooting’ Category

Cadê o telnet que tava aqui?!

January 24, 2018 Leave a comment

Depois de muito enrolar (foi lançado em Setembro/2017 – Link), resolvi fazer o upgrade do sistema operacional do meu Mac para o High Sierra (10.13.3).

E algumas coisas pararam de funcionar… como meu .Net Core SDK 1.1. Mas com a ajuda do Romanão que já tinha feito o upgrade… vi que era só atualizar/instalar o .Net Core SDK 1.1 novamente que ele voltaria a funcionar e funcionou! 🙂

Nas atividades corriqueiras do dia-a-dia precisei verificar a conectividade com uma aplicação e vamos ao primeiro teste de conectividade:

[16:00:39] – [Thiago ~]$ telnet

-bash: telnet: command not found

WTF?! command not found?!

https://discussions.apple.com/thread/8103628 – Foi removido mesmo.

Mas, ainda tem o telnet no homebrew! Ufa!

Eu já tinha o homebrew, mas se você precisar instalar, é só rodar esse comando:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Outras informações sobre o homebrew: https://brew.sh/index_pt-br.html

Com o ele, podemos instalar o telnet com o seguinte comando:

brew install telnet

Abraço!

Advertisements

Debug adapter process has terminated unexpectedly VS Code

November 15, 2017 Leave a comment

CENÁRIO:

Na vida usando, e usando muito, o Visual Studio Code com projeto .NET Core, fui debugar meu projeto… mas deu erro 😥

Deu erro pra DEBUGAR?! WFT?!

Pra quem quiser começar a experimentar o Visual Studio Code: https://code.visualstudio.com/

Estou bem satisfeito usando no Mac OS. É muito rápido! Sublime virou só bloco de notas mesmo. Rs

ERRO:

Debug adapter process has terminated unexpectedly

SOLUÇÃO:

Fechei e abri o VS Code e reiniciei o Mac (depois de várias semanas, mas é preciso) e nada resolveu.

Pesquisando um pouco, descobri que tem um console do Visual Studio Code que não é o habitual da “IDE”, onde estava procurando por erros:

Picture1

Mas nada de mensagem de erro nesses console.

Então, descobri este outro console “F12” do Visual Studio Code:

Help > Toggle Developer Tools

Picture2

Neste console havia um erro informando que não conseguia achar o “c# extension asset”. Então, pra resolver, desinstalei e instalei novamente o C# Extension do Visual Studio Code.

Picture3

Com isso, ele reinstalou o debugger e tudo voltou a funcionar! J

Abraço!