Archive

Posts Tagged ‘Central Administration’

Search has encountered a problem that prevents results from being returned. If the issue persists, please contact your administrator

September 8, 2014 Leave a comment

Olá! J

Cenário:

 

Após aplicar o SP1 no SharePoint 2013 e começar a validar os sites e serviços existentes da FARM encontrei um problema ao validar o funcionamento da busca/pesquisa dos sites que usam o serviço de busca do SharePoint.

 

ERRO:

Ao tentar utilizar a busca do site era apresentado o seguinte erro:

 

“Search has encountered a problem that prevents results from being returned. If the issue persists, please contact your administrator”

 

E ao pesquisar nos eventos gerados nos logs do SharePoint (ULS), encontrei o seguinte:

 

“SearchServiceApplicationProxy::Execute–Error occured: System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Tried IMS endpoints for operation Execute: Operation sent to IMS failed:

 

Resource saturation, try again later. (Fault Detail is equal to An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is: Microsoft.SharePoint.SPException:

Tried IMS endpoints for operation Execute: Operation sent to IMS failed: Resource saturation, try again later.”

 

SOLUÇÃO:

 

O erro do ULS cita, talvez, um problema de “recursos disponíveis”… quando fala de “resource saturation”, mas ao checar a condição do servidor vi que só estava consumindo 10% de memória de RAM e o CPU estava uma utilização bem baixa. Então não pode ser falta de recurso.

 

Ao pesquisar um pouco mais, percebi que um dos serviços do SharePoint estava “congelado” no estado “Starting”… Ou seja, não conseguiu subir. Tentei reiniciar o serviço, mas sem sucesso. Continuou no estado “Starting”.

 

Nome do Serviço: Search Host Controller Service


 

Para corrigir, re-provisione o serviço com esse script powershell:

 

$sh = Get-SPServiceInstance | ? {$_.TypeName -eq “Search Host Controller Service”}
$sh.Unprovision()
$sh.Provision($true)

 

Ou este:

 

$SA = Get-SPServiceInstance | Where {$_.Status -like “Provisioning”}

$SA.Unprovision()

$SA.Provision()

 

Depois que executar com sucesso, o resultado esperado será o serviço iniciado corretamente e a busca voltará a funcionar.


Abraço!

Advertisements

Conhecendo os Nomes Dos ApplicationPools de Serviço do SharePoint 2010 no IIS Manager

June 12, 2012 2 comments

Olá! Smile

Já faz um tempinho que não escrevo nada no blog… sorry! SharePointeando por aí, mas encontrei um tempinho pra aparecer por aqui hoje. (Sim, eu sei, ÀS 1h00 AM!! rs)

Cenário:

Quando criamos os Service Applications (figura 1) na Central Administration do SharePoint, o SharePoint cria Application Pools (ou utiliza já existentes) no IIS, e, para nossa surpresa (e não para nossa Alegria!), ele coloca GUIDs (figura 2) nos nomes!

Figura1:

image

Figura 2:

image

Se eu tenho poucas (como é o caso da minha máquina de desenvolvimento) na tentativa e erro, chego no AppPool que preciso, sem demorar muito. Mas, e se tenho diversos serviços na FARM e de forma isolada (1 pool para cada serviço)? Loucura Total!

Sabendo qual dos Application Pools queremos “trabalhar”, facilita demais operações de manutenção e/ou troubleshooting (esse último caso, o mais comum!). Então vamos lá!

SOLUÇÃO:

Pra quem conhece, sabe que o PowerShell opera milagres na vida de um Administrador Microsoft.

Eu não sou tão heavy user de cmdlets PowerShell, mas os mais simples sempre estão na ponta dos dedos!

Eis que temos mais um bem simples:

Get-SPServiceApplicationPool | select Id, Name

Com esta linha de comando, para ser executado no SharePoint 2010 Management Shell (ou no PowerShell com Snap-In para SharePoint), listamos todos os Application Pools de Serviços da FARM, selecionando o Id (Guid) e o nome que demos ao Application Pool quando criamos o serviço na Central Administration.

image

É isso aí, até mais! J

Abraço!

An IIS web site by the name of SharePoint Central Administration v4 already exists on this server

November 2, 2010 6 comments

Overview:

Na sequência do meu post anterior (https://thiagottss.wordpress.com/2010/11/02/microsoft-sharepoint-server-2010-encountered-an-error-during-setup-one-or-more-required-office-components-failed-to-complete-successfully/), ainda recuperando meu ambiente de desenvolvimento, encontrei mais um probleminha… Eu já tinha um SharePoint instalado anteriormente, e ao iniciar uma nova instalação…

Erro:

Ao rodar o SharePoint Configuration Wizard, me deparo com o seguinte erro:

image

image

A nova instalação do SharePoint não consegue prosseguir por que já existe um site e um AppPool da Central Administration do SharePoint criados (do meu antigo ambiente).

Solução:

Esse erro é mais tranquilo. Vá até o IIS Manager, e remova os site e o AppPool criados na instalação anterior do SharePoint.

Removendo Site:

image

Removendo o AppPool:

image

Agora é só rodar o SharePoint Configuration Wizard novamente.

image

image

Abraço!